i2c / 2wire usage

Questions for programming 8051 microcontrollers in C or assembly using SDCC

Re: i2c / 2wire usage

Postby brennen » Mon May 25, 2015 6:44 pm

Just to verify, you do have the appropriate pull-up resistors in place when you're using the nRF24LE1 board, right? If not, then you may not see any activity whatsoever on I2C.
brennen
Site Admin
 
Posts: 395
Joined: Sun Aug 17, 2008 2:15 pm

Re: i2c / 2wire usage

Postby baruch » Mon May 25, 2015 6:51 pm

I believe that the i2c code pretty much requires a response and doesn't handle timeouts at all. If the process hands it means that there was no answer to the request.

I suggest that you first make sure that something gets sent on the SDA/SCL lines with a logic analyzer, if it doesn't make sure you are wired properly to the correct pins, make sure that you are using the correct chip model (24 pin, 32 pins or 48 pins) and that you are properly wired to the pins you intend to be. That should be your first verification step.
baruch
 
Posts: 14
Joined: Mon Nov 17, 2014 10:15 am

Re: i2c / 2wire usage

Postby 07albi » Tue May 26, 2015 11:29 am

Thanks for replies.

Actually, I, kind of, found the problem. Until now, I was using two nrf24le1 chips. On both of these, the I2C was not working. Out of desperation, I tried to program the same code on another nrf24le1(same type) I bought, and it did work. I am not sure how that could happen, because everything else I tried worked on those two "faulty" chips, bot not the I2C.

Thanks for answers anyway
07albi
 
Posts: 4
Joined: Thu May 21, 2015 7:45 am

Previous

Return to 8051 Programming

Who is online

Users browsing this forum: No registered users and 1 guest

cron